Deployment error web.config is invalid IIS Web Site


Error :

Deployment error “The web.config is invalid on this IIS Web Site”

I’ve developed a web part that deploys and works properly in my DEV environment. When I attempt to deploy to PROD I get the following error:

SOMESERVER : https://sharepointtechnicalsupport.com/ : SharePoint – 41981 :
Error: The web.config is invalid on this IIS Web Site:

C:\Inetpub\wwwroot\wss\VirtualDirectories\41981\web.config.

SOMESERVER : https://sharepointtechnicalsupport.com/ : SharePoint – 41981 : Error: The web.config is invalid on this IIS Web Site:

C:\Inetpub\wwwroot\wss\VirtualDirectories\41981\web.config.

SOMESERVER1 : https://sharepointtechnicalsupport.com/ : SharePoint – 23994 : Error: The web.config is invalid on this IIS Web Site:

C:\Inetpub\wwwroot\wss\VirtualDirectories\23994\web.config.

None of these virtual directories exist.

Solution :

In Central Administration-> Operation-> Services on Server, please stop the Windows SharePoint Services Web Application service, SharePoint will remove the sites in IIS. And then start the Windows SharePoint Services Web Application service again, SharePoint will recreate the sites in IIS based on information stored in configuration database.

A SharePoint web application can have several zones, each zone will have a separate site in IIS. You will not see all the zones in Central Administration->Application Management->Web Application List. You can find the information in Central Administration->Operation->Alternate Access Mapping.

Advertisements

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s