Tag Archives: problem-opening-sharepoint-site-sharepoint-designer

WebHost failed to process a request service client.svc cannot be activated

WebHost failed to process a request service client.svc cannot be activated

Advertisements
Advertisements

WebHost failed to process a request service client.svc cannot be activated

I installed SharePoint 2010 and SharePoint designer 2010. If i try to open a site with the SharePoint designer it tries to open the site but gives a error in the event log is the following: "WebHost failed to process a request service client.svc cannot be activated"

WebHost failed to process a request.

Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/11404313

Exception: System.ServiceModel.ServiceActivationException: The service '/_vti_bin/client.svc' cannot be activated due to an exception during compilation. The exception message is: This collection already contains an address with scheme http. There can be at most one address per scheme in this collection.

Parameter name: item. ---> System.ArgumentException: This collection already contains an address with scheme http. There can be at most one address per scheme in this collection.

Parameter name: item

at System.ServiceModel.UriSchemeKeyedCollection.InsertItem(Int32 index, Uri item)

at System.Collections.Generic.SynchronizedCollection`1.Add(T item)

at System.ServiceModel.UriSchemeKeyedCollection..ctor(Uri[] addresses)

at System.ServiceModel.ServiceHost..ctor(Type serviceType, Uri[] baseAddresses)

at System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(Type serviceType, Uri[] baseAddresses)

at System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(String constructorString, Uri[] baseAddresses)

at System.ServiceModel.ServiceHostingEnvironment.HostingManager.CreateService(String normalizedVirtualPath)

at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)

at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

--- End of inner exception stack trace ---

at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)

Process Name: w3wp

Process ID: 3464

Solution :

What happened I created a site and in IIS I made a new binding so there was http://microsoftsharepointsupport.blogspot.com default from sharepoint and http://www.microsoftsharepointsupport.blogspot.com this is a multiple binding which caused the error.

Advertisements
Advertisements
Advertisements
Site not appear in IIS Manager

Site not appear in IIS Manager error opening in SharePoint Designer

Advertisements
Advertisements

Site not appear in IIS Manager error opening in SharePoint Designer

I have created a site collection and then create two team sites on SharePoint server. Sites are working fine from central Admin but Site not appear in IIS Manager. Also when I try to edit a SharePoint site on SharePoint designer 2010 following error comes.

Unable to open website following causes:

  1. The web server may not have SharePoint installed.
  2. The web server may be temporarily out of service.
  3. If you are connecting through a proxy server the proxy settings may be incorrect.
  4. An error may be occurred in the web server

The IIS manager only showing the following sites SharePoint 80 and SharePoint central admin

When I try to create a site on SharePoint designer following error comes:

The web site must be created on a server that is running Microsoft SharePoint foundation server please choose another location.

I have installed SharePoint server 2010, SharePoint foundation server 2010 and SharePoint designer on my pc.

Solution :

* In IIS Manager, you're only going to see the Web apps, the site collections and sites are wont show up (if you have another web app that isn't showing up, that's a bigger issue. I'd delete it and try to recreate it.

* The SharePoint Designer issue, I've had before. For me, the issue was a firewall setting. But basically if you can get to the pages with the browser, make sure you have correct permissions set for your login, etc.

Advertisements
Advertisements